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Designing a Pond
This course is for the 2023 Release 1 version of:

OpenSite Designer CONNECT Edition
OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos 

for this course are available on the LEARNserver.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust 
accordingly.

Have a Question? Need Help?
If you have questions while taking this course, you can submit questions to the Civil Design Forum on Bentley Communities 
where peers and Bentley subject matter experts are available to help.

Course Level: Intermediate

https://communities.bentley.com/products/road___site_design/f/geopak-inroads-mx-openroads-forum
https://communities.bentley.com/products/road___site_design/f/geopak-inroads-mx-openroads-forum
http://learn.bentley.com
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Course Overview

This class will look at how to create a pond from a terrain model and to add attenuation to the drainage system.

OpenRoads Designer technology was used to build a pond and a terrain from that pond, so it is all fully parametric. The file has been 
referenced into the imported drainage network file.

If you do need to modify the volume and the terrain of this pond at any time you can come back to this file, change the values and of course 
the OpenRoads Designer model will automatically update and therefore you can use this for your pond hydraulics.

The class also covers how to place headwalls to outfall into the pond for the mainline drainage, create a Pond Outfall structure with vortex 
valve. We will also create pipes connecting all the structures, asses their invert levels to ensure that they have a reasonable gradient.

Finally, we will compute a scenario that will assess the whole network
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Getting Started

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software, and the ones used for this training are installed during the 
software installation. 

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

3. Open an existing file.

a. Select Browse.

b. Browse to C:\Bentley Training\Designing a Pond or other folder where you unzipped the dataset files.

c. Select the file Mainline-Drainage-Imperial.dgn [Mainline-Drainage.dgn] and click Open.

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact for 
the training courses. However, note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full 
information is available at Bentley Communities - Product Realignment.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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Exercise 1: Completing the Imported Proposed Drainage Network

Description
In this exercise, you will add Inflow Headwalls, a Pond Outlet Structure to the pond, and then add an Outfall for the system and connect the 
nodes with pipes

Skills Taught
 Open a design file and check the references

 Place Nodes using AccuSnap

 Place Pipes

 Review and modify the inverts of the pipes



Copyright © 2024 Bentley Systems, Incorporated 5DO NOT DISTRIBUTE - Printing for student use is permitted

Checking Project Reference

In this section you will asses the reference files that are attached.

1. On the Home ribbon, click Attach Tools > References.

Note that References have already been attached and some have the Display icon clicked to turn off the Default/ Default-3D model.

a. Check the Default-3D model References also.

b. Put focus back on to View 1, by clicking on its title bar.

c. The Default model References are shown below.

The file has existing and design surface terrains, the mainline corridor, the high/low points of the design terrain and the pond terrain.

The Mainline-Pond.dgn contains the Geometry of the Layout of the Pond.

Note the F7 shortcut has been selected to turn off Construction Class elements. This is a toggle on/off and can be used as and when 
required.
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Place Headwalls and Outfall

In this section you will place two Inflow Headwall will first be placed into the pond. Then we will place the Outfall Node.

1. Select Drainage and Utilities Workflow.

2. On the Layout ribbon, 

a. Select, Layout > Place Node.

b. In the Place Node dialog, check Vertical Offset, set value to 0, 0

c. Set the Feature Definition > Node > StormWaterNode > Headwalls > Sloped End Section, 
Concrete > Training Headwall

d. In the Name Prefix type IH_1.

The Back-Of-Berm-Profiled D-EWKS-Back of Bench has an elevation of 36.75ft [11.2m]

e. At the Select Reference Element for Elevation. <Reset> to Type Elevation 
prompt, Reset, and type an elevation of 36.75ft [11.2m].

f. In the Default view snap to the point in the top right of the pond.

g. Data point 

h. Rotation Mode > Absolute and set the Rotation to around 200 degrees and 
data point.

3. Place a second Headwall by snapping to the point below and left of the first 
Headwall.

a. In the Name Prefix > IH_2.

b. At the Select Reference Element for Elevation. <Reset > to Type Elevation 
prompt, Reset, and type an elevation of 36.75ft [11.2m].
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c. In the Default view snap to the point in the top middle of the pond.

d. Data point 

e. Rotation Mode > Absolute set the Rotation to around 150 degrees and data point.

f. Esc to exit the command.
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4. The Default-3D view displays the placed Inflow Headwalls.
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An Outfall for the conveyance system is required. 

5. On the Layout ribbon, 

a. Select, Layout > Place Node.

b. In the Place Node dialog, check Vertical Offset, set value to 0,[0].

c. Set the Feature Definition > Node > StormWaterNode > Outfalls > Training Outfall

d. In the Name Prefix > OF_1.

e.  At the Select Reference Element for Elevation. <Reset> to Type Elevation 
prompt, Reset, and type an elevation of 24.5ft [7.5m].

 In the Default view snap to the point below the pond.

f. Data point 

g. Rotation Mode > Absolute and set the Rotation to around 145 degrees and 
data point.
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A Pond Outlet Structure is required to control flow from the pond to the Outfall.

6. On the Layout ribbon

a. Select, Layout > Place Node.

b. In the Place Node dialog, check Vertical Offset, set value to 0,[0]

c. Set the Feature Definition > Node > StormWaterNode > Pond Outlets > Pound Outlet Structure.

d. In the Name Prefix > POS-1.

e. At the Select Reference Element for Elevation. Reset to Type Elevation prompt, Reset, and type an elevation of 36.75ft [11.2m].

f. In the Default view snap to the point on the top of the pond bund.

g. Rotation Mode > Absolute and set the rotation to around 45 degrees and data point.
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Place the Pipes

In this section you will now place the pipes connecting the Headwalls to the Drainage System and the Pound Outlet 
structure to the Outfall.

1. Select Layout > Layout > Place Conduit.

a. In the Place Link Between Nodes dialog, set the Feature Definition > Conduit > StormWater > Pipes > Circular > Storm Water 
(Concrete).

b. Set the Description > 18” [450mm], this is the Catalog Conduit Pipe Size Label.

In the 2D View 1 follow the prompts. 

c. Select, Start Node > (Road Edge Channel Inlet) SO-2

d. Select, Next node to make a connection > (Headwall) IH_1.

e. Repeat for the (Headwall) IH_2, and the (Pond Outlet Structure) POS-1 to the (Outfall) OF-1.

f. Esc to exit the command.

The connections are displayed in both the 2D and 3D views. The connections can be modified later if the snaps to the 
Connection Regions are incorrect.

The placing of the pipes should resemble the layout in the following images.
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The pipe from the Pond Outlet Structure requires an invert elevation just above the bottom of the pond so we can get water to the Outfall.

g. Select the pipe SS-11 from the SO-2 catch basin that connects to the Inflow Headwall IH_1.

h. From the Context Sensitive Toolbar select > Utility Properties
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From Utility Properties see the Length (Scaled) (m) is 72.730ft [22.168m]

We need a reasonable slope from the Catch Basin SO-2 to Headwall IH_1, so we are going to amend the IH_1 invert to 31.62ft [9.605m]

Note: When Set Invert to Stop? Is set to True the Inflow Headwall Invert will control the incoming pipe invert. 

2. Select > (Headwall) IH_1

a. From the Context Sensitive Toolbar select > Properties.

b. Set the Invert Elevation > 31.62ft [9.605m].

3. Re-select the pipe SS-11

a. Check the Invert (Stop) from Utility Properties. 

Note: The Inflow Headwall invert was modified so this adjusted incoming pipe invert.
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4. Select > (Headwall) IH_2

a. From the Context Sensitive Toolbar select > Properties

b. Set the Invert Elevation > 34.1ft [10.376m].

5. Select the pipe SS12

a. Check the Invert (Stop) from Utility Properties. 

b. Close the Utility Properties dialog.
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6. Select > (Pond Outlet Structure) POS- 1 

a. Modify the Invert > 30.6ft. [9.300m], the bottom of the pond has an elevation of around 30.2ft [9.200m].
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Exercise 2: Place Pond

Description
This exercise will look at creating a pond to control flow rates by storing floodwater and releasing it slowly once the risk of flooding has 
passed.

Skills Taught
 Place Pond

 Review the Pond Hydraulics

 Review the Inflow Headwall Hydraulic properties

 Review the Pond Outlet Structure properties
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Place the Pond

In this section you will now place the pond.

1. Set View 2 Default 3D as the active view. Turn off the Level Display of the Components in the Mainline-Pond.dgn reference.

This will help with the selection of the Pond Terrain Model

2. Select, Home > Primary > Level Display

a. Select Reference > Mainline-Pond.dgn

b. Uncheck levels > D-Comp-EWKS-Fill and D-Comp-EWKS-Cut

Note the top elevation of the pond is 36.75ft [11.200m]. This could be checked using Analyze 
Point. 

3. Select Layout > Layout > Place Pond. 

a. Set Pond method > From Terrain Model 

b. Check on Maximum Water Elevation and set a value of 36.0ft [11.000m]. 

c. Set the Feature Definition > Drainage Area > Pond > Pond. 

d. Name Prefix > P-1. 

e. Data point in the Default view to accept the Pond method. 
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f. Select the Design-Contours-Pond Terrain Model from the Default-3D view.

Move the cursor back into the Default view. 

The prompt displays the lowest and highest elevation of the Design-Contours-Pond 
Terrain Model. The Maximum Water Elevation is set in the Place Pond dialog. 

g. Data point to accept the elevation. 

h. Set View 1 Active, Data point anywhere within the bottom of the pond to Select 
Point Within Pond Area

i. Select an Inflow for the pond, select > (Inflow Headwall) IH_1. 

j. Select an Outflow for the pond, select > (Pond Outlet Structure) POS-1. 

k. Data point to Accept the Boundary. 

You can now see the Pond Boundary in the Default view. 
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4. Select Pond Boundary and from the Context Sensitive toolbar, Select > Utility Properties

You will see the Properties of the Pond

a. Select Physical > Elevation-Area > Collection of 3 items. 

b. Select the ellipse to view the collection items.

The collection has been built by finding the surface area at every unique 
elevation in the Pond Terrain Model, so the collection correctly models every 
elevation at which the surface can change.

The elevation of 35.925ft [10.95m] comes from a feature in the pond that sits just below the top of the bund. 

If the value for Area on line 1 is set to 0.000, change it to read 0.0287.

c. Select OK to close the dialog. 

d. Close the Properties dialog.
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Check the Inflow Headwall Properties

In this section you will review and change the Inflow Headwall Properties

1. The Inflow Headwall properties will now have changed. The Boundary Condition Type was Free Outfall. 

2. Select > (Inflow Headwall) IH_1. 

a. From the context sensitive toolbar Select > Utility Properties. 

The Boundary Condition Type is now set to Boundary Element. 

The Network Boundary Type is Discharge to Pond and is now linked to the newly 
created Pond P-1. 

b. De-select > (Inflow Headwall) IH_1

3. Select > (Inflow Headwall) IH_2. 

a. From the context sensitive toolbar Select > Utility Properties. 

The Inflow Headwall will discharge into the pond

Change the Boundary Condition Type > Boundary Element. 

b. From the drop down and Select > Boundary Element 

c. Select > P-1 as the Boundary Element.
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Check the Pond Outlet Structure Properties

In this section you will review the Pond Outlet Structure Properties

1. Select > (Pond Outlet Structure) POS-1. 

2. From the context sensitive toolbar, Select > Utility Properties. 

The Upstream Pond now shows the P-1 feature. 

3. Under the Pond Outlet Property 

a. Set Has Control Structure > Yes 

b. Click the Ellipsis in the Composite Outlet Structure property. 

c. Select <Edit Composite Outlet Structure>. 

The Composite Outlet Structure dialog appears. 

d. Select New > Composite Outlet Structure 

e. Rename > Composite Outlet Structure 
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f. Set the Headwater Type > Use Pond for Headwater Range. 

g. Set Pond to < select from drawing> and Select > P1. 

h. Set the Tailwater type > Free Outfall 

4. Right click on the Composite Outlet Structure, Add and Select > Vortex Valve. 

A Vortex Valve is required to control the discharge from the pond. 

a. Rename > Vortex Valve. 

b. Set the Flow Direction > Forward Flow Only. 

c. Set the Elevation > 30.5ft, [9.300m]

(Remember the bottom of the pond is @30.2ft, [9.200m]

5. Select Category for the Vortex Valve, select the drop down. 

a. Select > Edit

b. Select > Import from Library

c. Select > BE-SXH > BE-SXH-4”, [BE-SXH-102mm] 

The selected Vortex Valve does not have enough Head for the pond.

The Maximum-Minimum(Headwater) difference is 6ft, [1.8m]

Note: For Imperial users there is no need to do step 6 below.
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6. Click in the Head (m) blank cell next to the asterisk

a. Under the Head Column > 1.8m

b. Tab across, then type a Flow (L/s) > 8

c. Tab again.

7. Close the dialog. 

8. In the Composite Outlet Structure Dialog

a. Under Category > Vortex Valve > BE-SXH-4”, [BE-SXH-102mm]

9. Select Compute from toolbar

This will update the Rating Table.



Copyright © 2024 Bentley Systems, Incorporated 24DO NOT DISTRIBUTE - Printing for student use is permitted

10. Select New > Composite Outlet Structures. 

Other flow control structures such as Orifices, Weirs etc. are available to control the discharge from your pond. 

11. Close the dialog. 

Ensure that the New Composite Outlet Structure is selected in the Utility Properties of the Pond Outlet. 

12. Close the Utility Properties.
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Exercise 3: Compute the System

Description
This exercise, you will activate CivilStorm, compute the scenario and review the results

Skills Taught
 License Activation

 Computing the Scenario

 Review the results of the Scenario
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License Activation

1. From Tools > License Activation > CivilStorm

The software checks to see what CivilStorm licenses are available. If a license and feature level have not been previously selected, a dialog 
is displayed.

If your organization owns any licenses, they will be shown in 
bold text.

If you have a row that uses bold text:

2. Click the Select button for that row.

3. Click > Done.

If you do not have a row that uses bold text:
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4. Click the Select button for the “Standalone, MicroStation, 250 Links” row.

A message asks whether you want to Check License Availability.

a. Click No.
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Computing the Scenario

1. From the Analysis ribbon, select Analysis Tools > Compute Center. 

a. Confirm that the Scenario is set to Pond Design. 

The Compute Center dialog always loads the current scenario. 

Review the other settings in the Compute Center dialog. 

Note: The setting for the Active Numerical Solver, is set to Explicit (SWMM Solvers). 

2. Click Compute

After a few moments, the SWMM Calculation Executive Summary dialog is displayed. 
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3. On the SWMM Calculation Executive Summary dialog select Storage

Note: the Volume and the Storage Maximum values.

4. Close the SWMM Calculation Executive Summary dialog.

5. Close the User Notifications dialog.

6. In View 2 Select > Pond Boundary 

a. From the context sensitive toolbar > Utility Properties

b. Scroll down and review the results.Particularily Percentage Full Maximum.

7. Close > Utility Properties

8. Exit the Software
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Summary

In this class we have looked at how to create a pond from a terrain model and to add attenuation to the drainage system.

We have also connected the drainage system to the pond by placing headwalls, a Pond Outfall structure with vortex valve. We also created 
the pipes connecting all the structures, assessed their invert levels to ensure that they have a reasonable gradient.

Finally, we will compute a scenario that assess the whole network.
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